A Short Introduction to Maple

CURM, Fall 2014

The following sections can be seen by clicking on the arrow to the left of the section name. To hide the
material, just click on the arrow again.

V The Basics

Maple documents are saved as .mw files. They consists of files created in Worksheet or Document
mode. This document has been created in Document mode.

To start a Maple session, just launch Maple. If you are using an older version of Maple, you may
choose to open a new document in the Worksheet or Document mode by going to the File mneu, then
selecting New, followed by either Document Mode or Worksheet Mode. In Maple 18, just select
New Document on the Start page.

VY Getting Help

To access the Help system, you can do one of two things:
* From the Help menu, select "Maple Help", or
* In the worksheet enter 7HelpOverview.

The Help system opens in a separate window with two panes. The left pane has the Help
Navigator, where you initiate seraches. The right pane displays the final search results.

In help pages, examples are not all executable, but you can open help pages as executable
worksheets. To do this, from the View menu, select Open Page as Worksheet. Then, a new
worksheet window opens. Alternately, you can just copy the Examples section to a worksheet.
To do this, from the Edit menu, select Copy Examples; then in the worksheet, use the Paste option
of the Edit menu.

VY Point-and-Click Interaction

Maple has many built-in features that allow you to solve problems quickly without learning new
commands.

Assistants: Using the Tools > Assistants menu, you can access tools to help you accomplish
various tasks. Ex. curve fitting, data analysis, optimization.

Palettes: palettes are collections of related items that you can insert by clicking. Palettes contain:
* symbols, like =, oo, V;

* layouts, like an item with a superscript and subscript;

* matrices;

* binary mathematical operators, like >; and
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» mathematical operations, such as definite integrals, with placeholders for the integrand,
variable of integration, and endpoints of the interval for integration.

YV Commands

Maple also contains a set of commands and a programming language.

The Maple Library: Commands are contained in the Maple library, which is divided into two
groups, the main library and packages.

The main library contains the most frequently used Maple commands.

Packages contain related special commnads for performing tasks from such disciplines as
statistics, linear algebra, etc.

Some Basic Commands

Note: The sections are made by choosing the Insert menu, then Section for the title (A Maple
Example) and Subsection here.

"n._

First, let us discuss data entry. To assign a value to a variable, use ":=". For example:

x =2

@2.1)

This assigns the value of 2 to variable x. These comments are made by hitting "Shift + Enter" after

typing the line, then choosing from the Insert menu Paragraph and After cursor (or by simply
selecting the "Text" option from above).

We can see that the variable x has been assigned the value 2 by typing the name of the variable.

X

In order to clear the value from a variable, we do the following:

X =X

This assigns the character 'x' to the variable x (in essence, clearing the variable).
We can also assign a list of data to a Maple variable. For example,

weight == [125, 138, 145, 119]
[125, 138, 145, 119]

2.2)

2.3)
2.4)

2.5)



We can easily find roots of polynomials. For example, let's find the roots of the polynomial x"2
-2x+1:

solve(x2 —2x+1 =O)
1,1 (2.6)

Note : to suppress the output of a command, conclude with a colon (:).

Now, we will free all variables, in effect making it like we just started our session.

restart
YV Piotting in Maple
We may also plot graphs easily in Maple. By default, Maple will produce a continuous plot.
plot(sin, -Pi..P1)
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We may also generate a scatter plot (i.e., a plot of a discontinuous or discrete set of data).




For example, if we would like to plot data representing height vs. age, where:
(Age, Height): (1, 75), (3, 92), (5, 108), (7, 121), (9, 130), (11, 142), (13, 155)

age = [1,3,5,7,9,11,13]

[1,3,5,7,9,11,13] (2.1.1)
height == [75, 92,108, 121, 130, 142, 155]
[75,92,108, 121, 130, 142, 155] 2.1.2)
pts = [seq([agelil, height[i]],i=1..7)]
[[1,75],[3,92], [5,108], [7,121], 19,1307, [11, 1427, [13, 155]] (2.1.3)
plot(pts, style = point, symbol = circle, thickness =2);
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VY Creating Functions
We will briefly discuss creating your own function, and using it to do various things.

First, to create a function, you may use the "->" command. For example, let's create the function




(x), where f(x) is the polynomial x> - 6x + 9.

f= x—x* —6x+9

x=x—6x+9 (2.2.1)
(2.2.2)
(2.2.3)
X
We can factor a polynomial, as well.
Jactor( f(x))
(x —3)? (2.2.4)

If you would like to save a worksheet, just go the the File menu and choose Save or Save As.
Worksheets are always given a .mw extension. Worksheets may also be exported as .pdf files.

You can also create functions of more than one variable. For example, we can create the function

g(x,y)=x2+y2-9.



g = (x,y)—>x2+y2—9

To plot a 3-d graph of g(x, y), we use the plot3d command, as follows.

|_plot3d(g(x,y),x=-4.4,y=-4.4)

V¥ Using the Linear Algebra Package

restart
Here, we will include the LinearAlgebra package. This loads all linear algebra functions.

with(LinearAlgebra)

[ &x, Add, Adjoint, BackwardSubstitute, BandMatrix, Basis, BezoutMatrix, BidiagonalForm,
BilinearForm, CARE, CharacteristicMatrix, CharacteristicPolynomial, Column,
ColumnDimension, ColumnOperation, ColumnSpace, CompanionMatrix,
CompressedSparseForm, ConditionNumber, ConstantMatrix, ConstantVector, Copy,
CreatePermutation, CrossProduct, DARE, DeleteColumn, DeleteRow, Determinant,
Diagonal, DiagonalMatrix, Dimension, Dimensions, DotProduct,
EigenConditionNumbers, Eigenvalues, Eigenvectors, Equal, ForwardSubstitute,
FrobeniusForm, FromCompressedSparseForm, FromSplitForm, GaussianElimination,
GenerateEquations, GenerateMatrix, Generic, GetResultDataType, GetResultShape,
GivensRotationMatrix, GramSchmidt, HankelMatrix, HermiteForm, HermitianTranspose,
HessenbergForm, HilbertMatrix, HouseholderMatrix, IdentityMatrix, IntersectionBasis,
IsDefinite, IsOrthogonal, IsSimilar, IsUnitary, JordanBlockMatrix, JordanForm,
KroneckerProduct, LA _Main, LUDecomposition, LeastSquares, LinearSolve,
LyapunovSolve, Map, Map2, MatrixAdd, MatrixExponential, MatrixFunction,
MatrixInverse, MatrixMatrixMultiply, MatrixNorm, MatrixPower, MatrixScalarMultiply,
MatrixVectorMultiply, MinimalPolynomial, Minor, Modular, Multiply, NoUserValue,
Norm, Normalize, NullSpace, OuterProductMatrix, Permanent, Pivot, PopovForm,
ProjectionMatrix, QRDecomposition, RandomMatrix, RandomVector, Rank,
RationalCanonicalForm, ReducedRowEchelonForm, Row, RowDimension,
RowOperation, RowSpace, ScalarMatrix, ScalarMultiply, ScalarVector, SchurForm,
SingularValues, SmithForm, SplitForm, StronglyConnectedBlocks, SubMatrix, SubVector,
SumBasis, SylvesterMatrix, SylvesterSolve, ToeplitzMatrix, Trace, Transpose,
TridiagonalForm, UnitVector, VandermondeMatrix, VectorAdd, VectorAngle,
VectorMatrixMultiply, VectorNorm, VectorScalarMultiply, ZeroMatrix, ZeroVector, Zip |

First, let's create matrices A and B and vector u. This is easily done using the palette to the left.

010
A=1]0 01
100

(x,3) =>x° +3° =9 (2.2.5)

3.1)



010

001
100
-7 -3 -8
B=|2 2 2
7 3 8
-7 -3 -8
2 2 2
7 3 8
2
u:= 1,3
8
2
3
8

Now, let's find the eigevalues and eigenvectors of B.

Eigenvectors(B)
5
-1 -— -1
2 4
0 1 1
== — 0
1 3 4
1 1 1

We can find the exponential of B:

expB = MatrixExponential(B, t)
5—¢ =36 -3 43¢ 3P —2e+5
-1+ e’ -1+
t 21 21 t 21t
e —4+4+3¢ 3¢ —3¢ -4+3¢ +2¢

Multiply the exponential of B and u.

v := MatrixVectorMultiply (expB, u)

(3.2)

(3.3)

(3.4)

(3.5)

(3.6)



50 —9 ' —39 &
-10 4 13 &*' 3.7
9¢' —40 +39 ¢’
Multiply A and B.

MatrixMatrixMultiply(A, B)

2 2 2
7 3 8 3-8)
-7 -3 -8

We can also find the determinant of a matrix.

Determinant(A)
1 3.9

Here is another way to create a function. Note: the semicolon lets us do multiple commands
simultaneously.

ul == unapply(v[1],1t);

u2 = unapply(v[2], t);
u3 == unapply(v(31,1);
t—50 —9¢ —39 ¢
t—-10 + 13 *'
t—9¢ —40 +39 ¢ (3.10)

Now, we can plot the three functions on one graph.

plot([ul, u2,u3], -0.001..0)
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Some Differential Equations Stuff

restart
del ==y'(x) +3-y(x) =0

Ey(X) +3y(x) =0

Find the general solution to the differential equation denoted by del.

dsolve(del)
y(x)=_Cle*
ic:==y(0)=1
y(0) =1
Solve del with initial condition ic.
dsolve({del, ic})
y(x)=e

de2 == y"(x) +3-y(x) =0

@.1)

4.2)

4.3)

(4.4)



d

— y(x) +3y(x) =0 4.5)
dx

Find the general solution of de2.

dsolve(de?2)
y(x) = CIsin(v3 x) + C2cos(V3 x) (4.6)
ic2:=y"0)=1
D(y)(0) =1 4.7)
Solve de2 with the initial conditions ic and ic2.

dsolve({de2, ic, ic2})

y(x) = L sin(\/?x) \/? -I—cos(\/Tx) 4.8)

3
Now, let's clear the variables del and de2 so that we can use them again.

del ='del'; de2 ="de2";

del

de2 4.9)
del = y'(x) =2-2(x) — 3-y(x);
de? == z'(x) =3-z(x) —2-y(x);

y(x)=2z(x) =3 y(x)

&l &la

z(x) =3z(x) —2y(x) 4.10)

Jens = {y(x), z(x) }
(r(x),z(x)} (4.11)

Find the series solution to the system of equations {del, de2} with initial conditions given. The
variables to be solved for have been stored in the variable fcns above.

dsolve({del,de2,y(0) =1,z(0) =1}, fcns, series)

52 5525 4 5 5. e 52,54
{y(x) 1 x+2x 6x+24x 24x+0(x),z(x) l—l—x—I—2 +6x 4.12)
25 45 506
+24x +24x +O(x)}
Find the numeric solution to the system, and store the result in the variable F.
F = dsolve( {del, de2,y(0) =1,z(0) =1}, numeric, fcns)
proc(x _rkf45) ... end proc (4.13)

F(1)

[x=1.,y(x) =2.66340068907918, z(x) =6.79994155048125 ] 4.149)

Include DEtools so that we may plot the solutions to the above differential equations.

with(DEtools)



[AreSimilar, Closure, DEnormal, DEplot, DEplot3d, DEplot_polygon, DFactor, 4.15)
DFactorLCLM, DFactorsols, Dchangevar, Desingularize, FunctionDecomposition,
GCRD, Gosper, Heunsols, Homomorphisms, IVPsol, IsHyperexponential, LCLM,
MeijerGsols, MultiplicativeDecomposition, ODElnvariants, PDEchangecoords,
PolynomialNormalForm, RationalCanonicalForm, ReduceHyperexp, RiemannPsols,
Xchange, Xcommutator, Xgauge, Zeilberger, abelsol, adjoint, autonomous, bernoullisol,
buildsol, buildsym, canoni, caseplot, casesplit, checkrank, chinisol, clairautsol,
constcoeffsols, convertAlg, convertsys, dalembertsol, dcoeffs, de2diffop, dfieldplot,
diff table, diffop2de, dperiodic_sols, dpolyform, dsubs, eigenring,
endomorphism_charpoly, equinv, eta_k, eulersols, exactsol, expsols, exterior_power,
firint, firtest, formal sol, gen_exp, generate_ic, genhomosol, gensys, hamilton_egs,
hypergeomsols, hyperode, indicialeq, infgen, initialdata, integrate _sols, intfactor,
invariants, kovacicsols, leftdivision, liesol, line_int, linearsol, matrixDE, matrix_riccati,
maxdimsystems, moser _reduce, muchange, mult, mutest, newton_polygon, normalG?2,
ode_int y, ode_yl, odeadvisor, odepde, parametricsol, particularsol, phaseportrait,
poincare, polysols, power equivalent, rational equivalent, ratsols, redode, reduceOrder,
reduce order, regular parts, regularsp, remove_RootOf, riccati_system, riccatisol,
rifread, rifsimp, rightdivision, rtaylor, separablesol, singularities, solve_group,
super_reduce, symgen, symmetric_power, symmetric_product, symtest, transinv,
translate, untranslate, varparam, zoom ]

DEplot({del, de2}, {y(x),z(x)},x=-2.2, [[y(0) =1,z(0) =1]], color =red, linecolor = blue)
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Do the same, but give the graph a title.

=.05, title

1], stepsize

(0) =

1,z

=blue);

red, linecolor

‘Example 1", color

DEplot({del, de2}, {y(x), z(x) }, x=-2..2, [[y(0)
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Get a plot of the integral curves.

phaseportrait([del, de2?], [y(x),z(x) ], x=-2.2, [[y(0) =1,z(0) =1]], stepsize = .05, title
= ‘Integral Curves, Ex. 1", color =red, linecolor = blue)



Integral Curves, Ex. 1
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Now, do a 3-d plot of the solution curve.

DEplot3d({del, de2}, {y(x),z(x)},x=-2.2,[[y(0) =1,z(0) =1]], stepsize = .05, title
= "3-d Plot of Solution for Ex. 1", linecolor = blue)



3-d Plot of Solution for Ex. 1
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